Media Transfer Framework-ESWare
概要
Media Transfer Framework-ESWareは、音声・映像通信機能を組み込む機器向けに開発された、組み込みシステム用のRTP/RTCPスタックです。リアルタイム音声通話や映像通信に必要なメディアストリーミング機能を、省リソースかつ高い移植性で提供します。IP電話、映像会議、監視カメラ、映像配信機器などにご利用いただくことで、限られた機器リソースを有効に活用し、お客様の製品に安定した音声・映像通信機能を組み込めます。製品仕様やシステム構成に合わせて柔軟に組み込めるため、さまざまな組み込み機器の製品化を支援します。
RTP/RTCPとは?
RTP(Real-time Transport Protocol)は、音声や映像などのリアルタイムデータをネットワーク上で伝送するためのプロトコルです。RTCP(RTP Control Protocol)は、通信品質や伝送状況を監視・管理するための制御プロトコルです。RTPとRTCPを利用することで、IP電話、映像会議、監視カメラ、映像配信機器などで、音声・映像データのリアルタイム通信を実現できます。

ご採用のメリット
Media Transfer Framework-ESWareはOS、CPU、コンパイラに依存しにくい設計をしています。そのため、お客様の製品仕様やシステム構成に合わせて組み込みやすく、さまざまな機器で音声・映像通信機能を実現できます。
RTP/RTCPスタックの上位には、Mediaセッション管理を含むフレームワークを備え、メディアストリーミング用のMSP APIを提供しています。これにより、お客様の製品に必要な音声・映像通信機能を、シンプルなインターフェースで組み込めます。限られたリソースを有効に活用しながら、製品仕様に合わせた柔軟な通信機能を実現できます。
特徴
限られたリソースでも音声・映像通信を実現
- 組み込み機器への実装に適したRTP/RTCPスタック
- 機器のメモリーなどのリソースを有効に活用しながら、リアルタイム通信機能を組み込める設計
さまざまな機器へ組み込みやすい高い移植性
- ANSI-Cのソースコードで記述し、特定CPUに依存しない設計
- CPUアーキテクチャへの依存を抑え、さまざまな組み込み環境への移植性を向上
- OSやコンパイラなど、お客様の既存環境に合わせて組み込みやすい構成
既存のネットワーク環境を活用
- TCP/IPスタックとの接続にUNIX系OSで一般的なBSD socket APIを採用
- Big Endian(*1)/Little Endian(*2)の両方の環境で利用可能
- 当社の「TCP/IP Stack-ESWare」と組み合わせて利用可能
- *1Big Endian: CPUが数値を扱う際のバイト順の1つで、上位バイトから順に格納する方式
- *2Little Endian: CPUが数値を扱う際のバイト順の1つで、下位バイトから順に格納する方式
音声・映像通信に必要な機能をまとめて利用
- RTCP XR(*3)により、通信品質をより詳細に把握可能
- Mediaセッション管理を含むフレームワーク
- MSP APIにより、製品に必要なメディアストリーミング機能を組み込み可能
- *3RTCP XR(RTP Control Protocol Extended Report):
RTCPの拡張仕様で、通信品質をより詳細に把握するためのレポート機能
実装実績
ARMプロセッサ、TI DSP(C6x)での動作検証実績があります。
その他のCPU、DSPへの組み込みについてもご相談ください。
メモリー使用量の目安
組み込み機器への実装を検討いただく際の参考情報として、開発実績に基づくROM容量とRAM容量の目安を示します。
| |
ARMプロセッサ |
TI DSP(C6x) |
| ROM容量 |
約60KB |
約90KB |
| RAM容量 |
約50KB |
約60KB |
- ※上記は開発実績に基づくおおよその値であり、お客様の環境での使用量を保証するものではありません。実際の使用量は、CPU、コンパイラ、最適化条件、機能構成、バッファーサイズなどにより異なります。RAM容量は、ストリーミングアプリケーションでAudio/Videoをそれぞれ1セッション使用する場合を想定しています。
サポート
自社開発の製品知識を活かし、お客様の製品仕様に合わせた組み込みやカスタマイズ、技術的なご相談を支援します。
TCP/IP Stack-ESWareとの連携
Media Transfer Framework-ESWareは、TCP/IPスタック上で動作するRTP/RTCPスタックです。お客様の環境にTCP/IPスタックが組み込まれていない場合は、当社のTCP/IP Stack-ESWareと組み合わせてご利用できます。RTP/RTCPとTCP/IPを同じESWareシリーズでそろえることで、音声・映像通信に必要なネットワーク機能を一貫した構成で組み込めます。これにより、機器構成に合わせた通信機能を実現しやすくなります。
構成
Media Transfer Framework-ESWareを組み込んだシステム構成例を以下に示します。
RTP/RTCPによる音声・映像通信機能は、TCP/IPスタック上で動作します。TCP/IPスタックが必要な場合は、TCP/IP Stack-ESWareと組み合わせてご利用いただけます。

- ※TCP/IP Stack-ESWareは、Media Transfer Framework-ESWareと組み合わせて利用できる関連製品です。詳細はリンク先をご覧ください。
概略仕様
サポートプロトコル
- RFC3350: RTPおよびRTCPの基本仕様
- RFC3551: RTPの音声・映像プロファイル
- RFC3611: RTCP XR (通信品質に関する拡張レポート仕様)
- IPv4/IPv6(オプション)
開発環境
上位アプリケーション向けAPI
ネットワーク・RTOS向けAPI
- BSD socket API (IPv4/IPv6)
- FreeRTOS API
提供内容
- Media Transfer Framework-ESWare(ソースコードライセンス)
- プログラマーズリファレンスマニュアル
- FreeRTOSインターフェースマニュアル
OKIアイディエスの強みと技術力
お客様の製品仕様に合わせた、リアルタイム音声・映像通信機能の実現を支援します。
- マイコンや組み込みOSを用いた開発の豊富な経験
- ネットワークコントローラーのドライバー開発に関する豊富な経験
- Media Transfer Framework-ESWareとネットワークコントローラードライバーをつなぐTCP/IPスタックの実装
- 本製品を活用した受託開発サービスにより、お客様の製品仕様に合わせた通信機能を実現し、市場投入に向けた開発を支援
導入検討時のポイント
RTP/RTCPスタックを組み込む際は、次の点をご確認ください。
- 必要なプロトコルや機能を利用できるか
- CPUやメモリーの使用量が、製品のリソース制約に収まるか
- 既存のハードウェアやソフトウェア構成に組み込めるか
- ほかの機種や開発環境へ移植しやすいか
- 製品ごとの仕様に合わせてカスタマイズしやすいか
OKIアイディエスのMedia Transfer Framework-ESWareは、組み込み機器に求められる省リソース性、移植性、柔軟性を考慮して開発しています。お客様の製品仕様やシステム構成に合わせた組み込みについてもご相談ください。
Media Transfer Framework-ESWareのリーフレット
まずはお気軽にご相談ください!
組み込み機器への音声・映像通信機能の組み込みや、製品仕様に合わせた開発をご検討の方は、お気軽にお問い合せください。設計段階から、OKIアイディエスが技術面から支援します。
無料相談も承っております。お問い合わせは、以下よりお願いします。
メルマガで最新情報、当社主催のWebセミナー情報を配信しております。お役に立てるよう配信してまいりますので、是非ご登録お願いいたします。
- ※記載されている会社名、製品名は、各社の商標または登録商標です。
- ※ここに記載されている仕様、デザインなどは予告なしに変更する場合があります。

- PDFの閲覧にはAdobe Readerが必要です。Adobe社のサイトからダウンロードしてください。